Impersonate Customer Not Working

corey34

Active Member
When I try to impersonate a customer from the backend, it redirects me to /customer/guest/index and then asks for me to log in.

What could be causing this?

I have custom extensions built but I deactivated them all to test this and it still does not work.

Thanks
 

corey34

Active Member
I found the problem. It was related to a feature that could not be added with an extension so one of the core files was modified.
 

twisted1919

Administrator
Staff member
It was related to a feature that could not be added with an extension so one of the core files was modified.
I am always willing to add new hooks to the application, so if you need a new one somewhere, please let me know, this will avoid modifying core files ;)
 

corey34

Active Member
Thanks @twisted1919. I don't fully understand what is happening with the modified code so I can't say what hook would be needed, but if interested, I can private message you with the exact details. The file that is modified is /apps/common/config/main.php.

I have an application that already has a separate login so the code was needed in order to bypass another separate login for the customer when using Mailwizz.
 

twisted1919

Administrator
Staff member
The file that is modified is /apps/common/config/main.php.
If you need to overwrite things from main.php(this gets changed at upgrades) best is to do it in the main-custom.php file, you'll notice it has same structure but a less things in it ;)
 
Top