I can't embed images inside emails using MW 1.3.7.8

@twisted1919

On previous MW version (1.3.7.2) it was possible to embed images inside the email during the campaign setup, now this option is not available. Why?

I have some problems with a customer that is telling me he need to give express permission to his email client program to download the images inside the campaign... because the images are "remote images"

Could you solve this? or... What can I do to be able to embed images inside emails to avoid the permission request to download the remote images that happens on certain email clients like RoundCube Webmail ?

Regards

Carlos
 

twisted1919

Administrator
Staff member
Embed images do more harm than good, that is the reason they are out and we won't be adding them again.

Tell your client that the email client will ask to display images anyway since there is a tracking pixel that has to be remotely loaded.
Also embed images will get you in spam and will make delivery super slow since message size is very large.
 

robthecomputerguy

New Member
Where do you get this information? I'm sending out 200,000 emails per month, and embedding images made no difference whatsoever in sending times, and now each email has an average of 23 attachments.

The system worked perfectly for us - our send times were unchanged and it solved an enormous number of server load issues for us.
 

twisted1919

Administrator
Staff member
@robthecomputerguy - if it worked for you it doesn't mean it worked well for everybody, i'm afraid.
The math is very simple here, embed 10 images of 2MB each and you have a > 20MB email. Transporting 20MB of data over the wire is not the same thing as transporting a few KB's so it takes time. There are also servers that don't accept emails larger than X size and if you hit such server your email will bounce.
Maybe if you rely your emails locally then it doesn't do a difference, but again, most people have to send them over the wire.

Anyway, the option is back, so you can use it again as you wish, it's up to you :)
 

robthecomputerguy

New Member
I have been troubleshooting this Saturday with very little sleep - so I will follow up later.

When you say it is back, what do you mean, as in where do I get this? The current version for download is 1.3.8.5 but my installed version is 1.3.8.6. Am I looking for 1.3.8.7?

[1.3.8.2 is the last version that had embed images, so I'm lost.]

Do we have a thread where you are alerting people of an intent to remove features that we can subscribe to? That thread should also include warnings for major functionality changes that might require checking of specific system functions before pushing the system live.

That said, I think Mailwizz is so successful that you should consider some professional features like a pending version that I could run those tests on without a whole separate installation. That's probably a silly idea, but I have like a 6 hour window on Sundays that means I can't just run updates when I want and this weekend has been an absolute nightmare; I was already rolling back to a previous version when you posted your message above.
 

twisted1919

Administrator
Staff member
When you say it is back, what do you mean, as in where do I get this? The current version for download is 1.3.8.5 but my installed version is 1.3.8.6. Am I looking for 1.3.8.7?
1.3.8.6 is latest stable version, then we have a thread where we push beta releases till we get a stable new version. We're very close. That version has the feature back.

Do we have a thread where you are alerting people of an intent to remove features that we can subscribe to? That thread should also include warnings for major functionality changes that might require checking of specific system functions before pushing the system live.
We don't have a thread given i don't remove things so often. From now on i will post polls and based on the results i will keep or remove a feature. Will do this for important stuff only.
You should always have a staging environment where you do your own tests before doing live stuff, this is beyond mailwizz, it's just how web development and testing is done.

That said, I think Mailwizz is so successful that you should consider some professional features like a pending version that I could run those tests on without a whole separate installation.
I'm not sure i follow this, please explain me in more details :)
 

robthecomputerguy

New Member
Yes, but I just typed above - the current version for download is 1.3.8.5 --- do you want me to install 1.3.8.5?

I do have a staging environment, but not embedding images isn't something that causes a problem for anyone until I send a few thousand emails emails in a campaign, and it only happens for some of those people because I don't allow an insane number of connections to my server by anyone - Google must be doing to pull all the graphics for EVERY SINGLE EMAIL in advance. When this option was "removed" it should be re-activatable for someone like me without an update, but [for example] something like "embedimages=1" in some wizzconfig.ini file. Instead I'm now waiting all day to figure out if you want me to install -.5 or for some reason .6 just isn't properly showing on the download screen.

I am so tired I didn't complete my thought - I meant you might think about features that might help in professional (high volume, either by # of days per week or # of mails sent) environments - and perhaps market a professional version with those features for a higher price. I'll go to suggestions and post more detail there. I have no great ideas here just an idea to think about some great ideas. :) (I really don't know what I don't know, but there are some things take me so much time to implement that I often don't.)
 
Last edited:

robthecomputerguy

New Member
Just to confirm, I have 1.3.8.6 and that option doesn't exist. So you're saying that you updated that version to allow for embedding images, but did not change version numbers?
 

twisted1919

Administrator
Staff member
Just to confirm, I have 1.3.8.6 and that option doesn't exist. So you're saying that you updated that version to allow for embedding images, but did not change version numbers?
No :-s I'm saying that i added back the feature in the 1.3.9.x version which is now considered beta.
 
Top