how to set up amazon ses

Jose Vega

Member
Hi, I followed your youtube tutorial and created an amazon web api server on my mailwizz. But when I try to validate the server I get this error:

  • The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details.
    The Canonical String for this request should have been
    'POST
    /
    host:email.us-west-2.amazonaws.com
    x-amz-date:20150523T083747Z
    host;x-amz-date
    8b24a576fbe2084b2dad33020a95a74515be3ea297f4f17f86b1cbafff3e0bb7'
    The String-to-Sign should have been
    'AWS4-HMAC-SHA256
    20150523T083747Z
    20150523/us-west-2/ses/aws4_request
    38381d2e7422595a4bf010446992a65a6386b7d124d338bb52b47ac15551a161'
Honestly i dont understand how amazon ses works. I just created the access key and secret access keys as you show in the video, and nothing else. Do I have to do something else?

By the way, I put the secret access key in the password field, but after saving the field is empty. I guess is for security reasons.
 

twisted1919

Administrator
Staff member
Hey,

Amazon is a bit hard to setup by nature, because that's how they decided to do things.
The above error you get tells me that you didn't properly generated the new user and permissions for the user.

The idea is that you generate a new amazon user and when you do it, don't check that checkbox that asks to generate new credentials. After the user is created, attach the PowerUser policy to him and then generate the keys and use them in mailwizz. It's important because the keys have to be generated after the policy has been attached.

If you do the above, i guarantee things will work just fine.
Thanks.
 
Hello ,

Im trying to config my amazon and look this :

  • User: arn:aws:iam::815114515835:user/MAUTONE is not authorized to perform: ses:SetIdentityFeedbackForwardingEnabled
I dont know how can be do this !
Some one help me please ?
Thanks
Anderson
 
I watched the video, read this thread and did everything in the exact order, but I have this error message when validating:
  • User: arn:aws:iam::897736661150:user/PantikaMail is not authorized to perform: SNS:CreateTopic on resource: arn:aws:sns:us-east-1:897736661150:MWZSESHANDLER
The only thing that is not the same as in the video is the list of 134 policies to choose from.

I chose that one
Screen shot 2015-07-02 at 8.38.53 PM.png

Is that correct?

What the solution?
 
No, I wasn't sure as the policies now do not look the same as in the video.

I looked further after a night rest and added a new policy.

Screen shot 2015-07-03 at 6.43.38 PM.png
So in fact you need the 2 policies in the image above for Amazon SES to work!

I was able to confirm the server and the email sent shows in the Amazon stats, so all is great.

Screen shot 2015-07-03 at 7.03.58 PM.png
For those who want to set up Amazon SES, follow the instructions to the letter, but for the part you add the policy refer to the screenshot above.

It's worth it to set up Amazon. When I requested my sending quota, I asked for 5,000 emails a week and they allowed 50,000 per day. That's much more that what I need at the moment!

Screen shot 2015-07-03 at 7.09.42 PM.png
When I started with Mandrill they gave me 500 emails per hour, and I am now at 18,235 per hour after a month.
 

Ron

Member
I tried with the above mentioned 2 policies as well and then generate a user access key but getting the same error

  • Unable to determine service/operation name to be authorized
 

Rob

Active Member
You have an issue with your amazon user credentials. Start the process again of creating the credentials as per the video, I promise you it works when followed properly.
 

Ron

Member
Same error again..

Used Amazon Web API

user created and attached 2 policies.
AdministratorAccess & AmazonSESFullAccess

Hostname as usual..

I am giving Access Key ID:as username and Secret Access Key: as password

Saved

Tried to Validate server and gives me the same error
  • Unable to determine service/operation name to be authorized
 

Rocky Rocky

New Member
Error on Validate server after Amazon Web api configuration.

error message as below:
  • Cannot send the confirmation email using the data you provided.
  • Here is a transcript of the error message:
  • Signature not yet current: 20160624T101520Z is still later than 20160624T100423Z (20160624T095923Z + 5 min.)

    Seems it's about timezone setting? but don't know how to fix it out?
    Can anybody help? thanks.
 

daemon

Member
Whenever sending a campaign amazon puts DKIM them. I would like to delete the dkim ( .header @ amazonses.com ) .
 

Rocky Rocky

New Member
Thank you @Vpul Shah ,
This error is occurring because of clock skew. This means that the time on my sever differs significantly from the time on the AWS server that is fulfilling my request.
I use below command fix it out (centos 6.5):

ntpdate ntp.ubuntu.com

now,it works .
 
Last edited:

Vpul Shah

Active Member
Correct.
When this service stopped, you get this error.

This is what you need to update.

Great you solved it.
 
Top