How to automate an email sequence

gottfried

New Member
Hello,

I tried today to setup an email sequence to a list of recipients and I would like to ask you how to automate it properly. Here what I want to accomplish:

Scenario 1:
1: Send E-Mail 1 automatically to someone who subscribed (by form or by me manually). This I managed to do.
2: Automatically send E-Mail 2 two days after E-Mail 1 was sent to the same list.

Scenario 2:
1: Same as Scenario 1
2: Send an E-Mail to everyone from step one who clicked on a specific link in the email.
3: Remove someone from the list when they answered to an email.

Thank you for your help.

Regards,
 

laurentiu

Active Member
Staff member Support Staff MailWizz 2.0 Tester
2: Automatically send E-Mail 2 two days after E-Mail 1 was sent to the same list.
You can use autoresponders to do that, on Campaign confirmation step set Autoresponder event > AFTER-CAMPAGN-SENT and Send after sending this campaign > Here select campaign name sent in step 1, Autoresponder time value > 2, Autoresponder time unit > Day

2: Send an E-Mail to everyone from step one who clicked on a specific link in the email.
For this you need to use segments, create a custom tag in your list which is updated when a specific link from campaign is clicked, you can change custom tag value on step: Campaign template > Change subscriber custom field on link click, then from your list create a segment based on that custom field and this segment will match only subscribers which have a specific value in some custom tag.

3: Remove someone from the list when they answered to an email.
For this you can use: Email Box Monitors - https://kb.mailwizz.com/articles/email-box-monitors/
 

gottfried

New Member
Hey Laurentiu,

thank you for your answer, will try to implement it like this and come back if it does not work :)

Regards
 

gottfried

New Member
Ok, I managed to get everything to work, except the last part. I setup an Email Box Monitor mailbox and set the conditions if it contains *, the subscriber should be set on unconfirmed.

Now I have two questions:

1: When I use the condition with * it should process any email which has any kind of characters in the body, correct?
2: Do I need to setup anything else? Or do I need to set something up, so the subscriber will send to the newly created email when answering an email from a campaign?

Thank you for helping.

Regards
 

laurentiu

Active Member
Staff member Support Staff MailWizz 2.0 Tester
1: When I use the condition with * it should process any email which has any kind of characters in the body, correct?
The asterix wildcard (*) matches everything.

2: Do I need to setup anything else? Or do I need to set something up, so the subscriber will send to the newly created email when answering an email from a campaign?
You need to add the cron jobs for email box monitors, please see article which i send to you there is explained all steps: https://kb.mailwizz.com/articles/email-box-monitors/
 

gottfried

New Member
Hello Laurentiu,

thank you for your answer. I did add the cronjob and the email-box-monitor-handler says it works successful. My question is, how will the replies from the recipients go into the newly created inbox when the email I have in the "Reply-to"-field is another one than the mailbox for the Email Box Monitor?

Easier explained:

I send my campaign from abc@mail.com.
When someone replies, they reply to abc@mail.com.
My Email Box Monitor mailbox is for the email xyz@mail.com.

Now how will a reply to abc@mail.com end up in the mailbox for xyz@mail.com? Is there a way to put xyz@mail.com into a Bcc or anything like that?

Regards
 

laurentiu

Active Member
Staff member Support Staff MailWizz 2.0 Tester
Thank you, but will I then get this email as well to abc@mail.com?
No, you will receive response only to email set on Reply-To, also if you want to set for all campaigns you can set Reply-to on your delivery server and make Force Reply-To > Always and this setup will be applied to all email sent with this delivery server.
 

gottfried

New Member
Hello,

thank you for the answer. I now managed to do it with an automatic forwarding of the email on the mailbox-level.

Regards
 

Amer

New Member
Hello,
After many hours trying to setup the EBM without success... I think I need help.

The procedure I followed:

Step1: I enabled the EBM
and I got "form has been successfully saved" message.

mailwizz1.jpg




Step2: I added the Cron job:
mailwizz2.png

Step 3: I added the EBM email account to my campaign in the field Reply-to .
I forwarded that EBM email to send to my preferred account as here.
mailwizz3.jpg


I sent a sequence of 3 emails. it suppose to stop the sequence for the email that replies. But it is not the case, the whole sequence continues.

Any idea on how to debug this?
I feel that the problem is in the cron job may be?

I will appreciate your help!

Thanks!
 

Amer

New Member
Are the emails moved in your other list as specified?
Thank you for your answer.
No, Nothing changes on the email, they are not moved to the new list.

To explain the flow more precisely.
- The email abc@domain.com is in List A and supposed to be moved to List B if it replies to the campaign 1 .
- Campaign 1 is a sequence of three emails sent with 15 minutes delay to List A
- abc@domain.com receives the first email and replies to the EBM campaign email, say EBM@domain.com
- Normally, After the 10 minutes cron Job, mailwizz shall check EBM@domain.com and if it finds any reply, it shall move abc@domain.com from List A to List B.
- By checking EBM on the server manually, it has actually received the email from abc@domain.com.
- Going back to sequence, after 15 minutes the second email is fired to List A and abc@domain.com receives the email.
-Nothing changed..abc@domain.com is still in List A.


The settings I used:
- To set up the EBM I used my ordinary mail server attached to my domain, thus mail.mydomain.com. The settings are like in the image above.
- I forwarded my EBM email to a third email where I supposed to receive the customer messages and answer them.
- The cron job is set as the image also. I tried 10 minutes, 2 minutes without any result. each time I Run it, it shows no output.

What am I missing?
 

Amer

New Member
Now I validated that the cronjobs are working perfectly also.
I changed the setting of the EBM cron job to run each minute. Here is my terminal results.

mailwizz4.jpg
 

Amer

New Member
Digging more,
I think that the email box monitor cannot connect to the server to manage emails. Because emails are well received, and forwarded, but never marked read or deleted in the inbox.

On the mailwizz interface, Email Box Monitor section, it says that if mailwizz accepts to save an email this implies also that it is working well and that it has access to it. Otherwise it wont accept to save it.

mailwizz5.jpg



Please note that I tried also to change the active pop server and used another outlook server to test. I changed the EBM and the Reply-to email in the campaign message.

Unfortunately, No success... The mailwizz doesnt read the emails from the EBM email.
please see here

mailwizz6.jpg


Any idea on what to do?
 
Last edited:

twisted1919

Administrator
Staff member
it says that if mailwizz accepts to save an email this implies also that it is working well and that it has access to it. Otherwise it wont accept to save it.
That's correct. Are you suing same PHP version in the web interface, like the one in command line? Usually this is the problem, different PHP versions...

Additionally, what you can do, is to run the email-box-monitor command manually, with the --verbose=1 flag to see what it says, like described at https://kb.mailwizz.com/articles/debug-send-campaigns-command/ but instead of send-campaigns, use email-box-monitors
 

Amer

New Member
Thank you!
I followed your advice and debugged using --verbose=1

The IMAP extension was missing from my PHP installation. I installed it successfully thanks to
https://kb.mailwizz.com/articles/the-imap-extension-is-missing-from-your-php-installation/

I am at 90% success now. The EBM was able to detect emails ONLY if I use the "email address as a detection method". When I try to detect using the Subscriber-UID it is not working.
Please check the terminal screenshot.
It says that No subscriber found for message ID 1. Even though the email is subscribed to List A, therefore it received the message in the first place.

mailwizz7.jpg

When I check the header of the message manually, I find the subscriber UID.

I checked the forum and found this
https://forum.mailwizz.com/threads/email-box-monitors-settings-priority.5562/

Did anything change from 2018? Any solutions?

THANKS!
 
Last edited:
Top