Hide unsubscribe url/link on the tag

icactive

New Member
Hi,
I'm setting up the first campaign and since the unsubscribe option has been set required (due to most provider requirement) i must always add unsubscribe tag on the template.
Only when i place the tag [unsubscribe], the long url is appear on the email. And looks messy. How can i hide the url, so people can only see a word "Unsubscribe this email" with generated anchor link to the unsubscribe page??

Look forward for a respond.

Thanks
 

twisted1919

Administrator
Staff member
Switch the editor in source mode and enter something like:
Code:
<a href="[UNSUBSCRIBE_URL]">Unsubscribe this email</a>
Then switch it back to visual.

You can also type the wording "Unsubscribe this email" in the editor, then select it and then press the link button from the toolbar. From the link menu, choose OTHER for protocol and in the URL field insert [UNSUBSCRIBE_URL] then hit the OK button.
 

Jamie Whittingham

Active Member
no no, I mean have a button dedicated to placing my above example into the editor
or even a block of HTML code that contains HTML for links to unsubscribe, report abuse and manage profile? all in one go.

I know you can code custom buttons for CKEditor, i just not sure how lol or which files to edit in MW to get it working.

thanks
 

twisted1919

Administrator
Staff member
Where are you redirected when pressing the unsubscribe link?
Does your list has confirmed subscribers, have you tried an actual test campaign ?
 

Tanya

New Member
Where are you redirected when pressing the unsubscribe link?
Does your list has confirmed subscribers, have you tried an actual test campaign ?
Did not understand your question.
I insert tag [UNSUBSCRIBE_URL] in the template link to unsubscribe. It does not substitute the actual link.
I made test campaign. I signed my addresses, and confirmed them.
 

Jesse Josserand

New Member
Here it is 3 years later and unsubscribe tags are still not working in a template test email.
Please help.
I've tried just putting either [UNSUBSCRIBE] or [UNSUBSCRIBE_URL] in an email in visual mode and in source mode.
When I send a test email, all I get is the unmodified tag -- no URL, no button.
If I go into source mode and add it thusly... <a href="[UNSUBSCRIBE_URL]">Unsubscribe</a><br />, I get the word "Unsubscribe" in the test email, but it is not a link, just text.
If I put the word "Unsubscribe" in my email text, then click the link button and use "Other" with the [UNSUBSCRIBE_URL] tag, the exact same thing happens ... just the word "Unsubscribe" appears in the test email and is not an active link nor a link at all.
 

Vpul Shah

Active Member
Can we include unsubscribe url by default for every customer for every email sent ? What the process for it ?
Yes Tarun, you can do that.

In Customer - Group - Campaign - Footer - you can set your content, so it will go by default with every email customer send.
 
Top