From email and unable to block issue

n.business

New Member
Issue 1: FROM Email Not Updating for Verified Sending Domains

Users are unable to use their own verified sending-domain email address in the FROM email field. Even after successfully verifying their domain by configuring the required SPF, DKIM, and DMARC records, the system continues to display and use the default system FROM email address.

Expected behavior:
Once a user's sending domain has been successfully verified, the user should be able to select and send emails from an email address associated with that verified domain.

Current behavior:
The system continues to show the system/default FROM email address.


============================================================================================

Issue 2: Admin Unable to Block Individual Campaigns

The admin is currently unable to block or prevent an individual campaign when a user submits or attempts to send a campaign that does not comply with Acceptable Use Policy (AUP), or applicable requirements.

Expected behavior:
Admins should be able to review, block, hold, or reject individual campaigns that violate company's policies, contain prohibited content, or otherwise present a compliance or deliverability risk.

Current behavior:
Admins do not have an option to manually block or stop a specific non-compliant campaign before it is sent.

This control should apply to individual campaigns without necessarily requiring the entire user account to be suspended or terminated.
 
Last edited:
Users are unable to use their own verified sending-domain email address in the FROM email field. Even after successfully verifying their domain by configuring the required SPF, DKIM, and DMARC records, the system continues to display and use the default system FROM email address.

Expected behavior:
Once a user's sending domain has been successfully verified, the user should be able to select and send emails from an email address associated with that verified domain.

Current behavior:
The system continues to show the system/default FROM email address.
Each delivery server has the option to allow this or not. You should allow them only verified sending domains. Look at the delivery server options and at sending domains. Additional info at https://www.mailwizz.com/kb/what-tracking-and-sending-domains-actually-are/

Issue 2: Admin Unable to Block Individual Campaigns

The admin is currently unable to block or prevent an individual campaign when a user submits or attempts to send a campaign that does not comply with Acceptable Use Policy (AUP), or applicable requirements.

Expected behavior:
Admins should be able to review, block, hold, or reject individual campaigns that violate Hevener’s policies, contain prohibited content, or otherwise present a compliance or deliverability risk.

Current behavior:
Admins do not have an option to manually block or stop a specific non-compliant campaign before it is sent.
There's an option where campaigns must be approved by administrators before they start sending, look in the customer settings or customer group settings, it is there. Also, you have an option to block a campaign from backend area, from campaigns, in the actions column. That option appears when a campaign is processing/sending.
 
Also, campaigns can be blocked if their subject/content contain various phrases/words, which you can set automatically in the settings.
 
About the verified sending domains for delivery servers, I have gone through the process severally wtih aws ses web api delivery method. The mail FROM email is always the system default even after the proposed domain as been verified.
 
Did you modify the delivery server as I mentioned above? Look at the "Force FROM" setting, by default it is set to Always, so it will force that from email from the delivery server always, but if you set it for everything except sending domains, then that will do what you're after, given your domain that you verified in amazon is also added as a sending domain in MailWizz.
 
I am sent a screenshot for what is enabled in the delivery server settings. Every other setting was set to "Never" asides this one. The user's domains are usually verified but still send with system default email
 

Attachments

  • Screenshot From 2026-10-01 20-25-01.png
    Screenshot From 2026-10-01 20-25-01.png
    26.2 KB · Views: 1
Back
Top