Failed to authenticate on SMTP server with username "..." using 2 possible authenticators

I'm getting this error when try to verify my Delivery Server.

Our delivery server is postfix server and i can sent email any other client with same credentials.

I have tried 3 different server but no luck.

Any advice?
Thanks
Belek
 

twisted1919

Administrator
Staff member
This has been discussed a few days back i believe.
You should check this stackoverflow post: http://stackoverflow.com/questions/...r-535-incorrect-authentication-data-when-send

However, the thing is that if you get that error on your server and i'll try from mine, i won't get it, so i believe it's also a matter of what you have installed on your host.
You could try connecting over ssl on port 465 and don't verify the cert.

Also, what mailer are you using from backend -> settings -> common ?
Try to switch between them and see if it makes any difference.
 

Manos

New Member
Probably the smtp authentication method, but this is not recommended.
Isn't there a method to have authentication enabled ?
 
@twisted1919 How can we get this error fixed for good and once for all. If some one doesnt have access to WHM/Cpanel. So how can this issue be fixed.? I have gone through https://kb.mailwizz.com/articles/fa...username-xyz-using-2-possible-authenticators/

And these

2) Make sure your password does not contain special chars like the & sign. If it does, change it so that it doesn’t.

3) If you are using CPanel, go into WHM > Tweak Settings > Allow all users to make external SMTP connections.

Dont apply to a person..
 

twisted1919

Administrator
Staff member
If some one doesnt have access to WHM/Cpanel. So how can this issue be fixed.?
That's not something we can help with. If cpanel configured your server in a way, it's cpanel which must undo this restriction.
The above error is not something waht mailwizz itself can fix. The above error is a result of limitations placed on the server.
What mailwizz can do, and what it does, is to offer some guidance, but that's all.
 

frm.mwz

Well-Known Member
make external SMTP connections
If that is disabled by the server admin (for various reasons, incl good ones),
then fortunately mwz has the web api sending options :)
And oft you can circumvent restrictions by using another port and SSL/TLS (which must be set/match the MTA on the receiving end).
 
The issue of using 2 possible authenticators is coming from customer's end.
WHM>Tweak Settings> allow external connection is enabled. Still getting this error.
Password doesnt contains any special characters.
php version is 7.0
 
Can you show with screen shots what exactly is cause/effect?

Not using any special characters in the password.

And have disabled it as well from WHM
 

Attachments

  • Screen Shot 2017-09-26 at 12.43.37 am.png
    Screen Shot 2017-09-26 at 12.43.37 am.png
    42.6 KB · Views: 25
  • Screen Shot 2017-09-15 at 12.44.41 am.png
    Screen Shot 2017-09-15 at 12.44.41 am.png
    16.9 KB · Views: 22

frm.mwz

Well-Known Member
Not using any special characters in the password.

And have disabled it as well from WHM
Can you switch on debugging and see what output you get?
Also, if you try to use the same DS with Thunderbird for a test message, what happens?
Have you tried sending anything via web api (easy sign-up w/ ElasticEmail to get 150K/month free)?
 
you switch on debugging

How to enable and from where?

Trying the same settings with thunderbird works like a charm. no issue with it.

All other third party SMTPs and settings are working great. This issue is coming when a customer is using their own SMTP and not everyone is encountering this issue.
 
Solution:

I think I solved it.
Failed to authenticate SMTP server with "email" using two possible authentications.
So, I was playing around and going crazy with this issue. This made me nuts and may make you or any one this forum as well.

The first thing was to understand the error.

The meaning of the error is that the SMTP server you are trying to verify is being verified by the same email id twice or there are two email ids using the same password to verify the server. This is the reason the error occurs.

So if you are using username and password, and e-mail (which is required) this error is most likely to come because you will be using username and e-mail for the authentication for the SMTP server.

Solution:

Remove the email from username and just keep the e-mail in the e-mail section which is required and let the password be in the password section. You should be good to go now. If you still facing the issue, see the guide present at:

https://kb.mailwizz.com/articles/fa...username-xyz-using-2-possible-authenticators/

The another issue can be of the password or firewall ( if you are using it)
 
Top