error in segmentation

emailwrks

Member
hey,

when im trying to segment a list of just over 100k, i get this error;

  • Current segmentation is too deep and loads too slow, please revise your segment conditions!
what does this imply in the segment essentially? As it saves it okay.

also how can i add more than 3 segment conditions

thanks
 

emailwrks

Member
what i'm trying to segment really isn't that heavy, so a lil confused as to why this kind of message is showing really.
 

emailwrks

Member
the total list size is 230,338. I have 8 custom fields on it, but only 4 of those columns are populated with data.


update - okay it appears to happen only when i try and add two different columns as seperate conditions to filter.

I am trying to filter by domain as well as previous list. If this cannot be resolved in the structure i intended, i would have to seperate all my data which is a pain.

how do i select more than one email domain in one filter;

email > contains > tiscali and hotmail for example

thanks for any help on this
 
Last edited:

Jeff Guynn

Member
also how can i add more than 3 segment conditions
This is the only part of your question I can answer. Go here: Backend --> Settings --> Customers --> Lists, and change "Max. segment conditions" to whatever you like. Be advised the cautionary tool tip when you click on this field: "...This affects performance drastically. Keep the number as low as possible".
 

emailwrks

Member
thanks jeff, that covers that one.

seem to be having an issue with the segments in terms of trying to exclude a domain

if i put email, "not contains", hotmail

i can still see hotmail domains in the matching subscribers shown for that segment
 

emailwrks

Member
still havent been able to solve my filter issue, when trying to filter out certain domains using 'email' 'not contains' 'hotmail' does not filter out all of hotmail addresses.

Funnily enough, when im using one condition of the below, it works fine, its when more than one condition is strung together as below, it doesnt work.

example of what im trying to do and matching subscribers;
example.PNG

thanks
 
Last edited:

emailwrks

Member
Hey rob,

I have tested, hotmail hotmail.com and @hotmail

In all of these tests, one condition works, but multiple conditions as above in my screenshot don't work

Thanks
 

Rob

Active Member
Hi

There is an option above the fields called "Operator Match" do you have it set to "all" or "any"?
 

Rob

Active Member
Just to be clear as to what you want to achieve, Are you trying to EXCLUDE all subscribers that have a hotmail or gmail email address?
 

Rob

Active Member
in that case you need to set the "Operator Match" to ALL and the fields "Operator" to "not contains".

I've just done it on one of my lists and it has filtered all emails correctly.
 

emailwrks

Member
Okay thanks rob, just given that a try and on first indications it has worked.

Weird though, I would have thought an absolute statement such as 'all' would mean it has to be met exactly or else the conditions don't get met. Hence the 'any' statement being more flexible. Thanks for your help on this however!
 

Rob

Active Member
The ALL statement in this case appears to mean ALL conditions to be included in the process of segmentation not that a subscriber should meet ALL conditions. Whether that is intentional I have no idea.
 

emailwrks

Member
thanks for the help.

only issue i have now is it doesn't work on large lists of 200k subscribers, i just get this message returned;

  • Current segmentation is too deep and loads too slow, please revise your segment conditions!
is there anyway to overcome this? Removing a couple of domains from a large list shouldn't really be too difficult
 

Rob

Active Member
Experiment with the value of Backend > Settings > Customers > Lists Tab > Max. segment wait timeout.
 
Top