Error Campaign

darrendave

New Member
I tried make 2 campaign
2 campaign not sent
and there are no report error
only said "pending-sending"

How to fix it?
 
@twisted1919 Sorry to bug you here :)

1) You try to run more campaigns than you actually allow from settings, so go to Backend -> Settings -> Cron and put 100 in the campaigns at once field, just as a test to see if it fixes your issue. If it does, lower this number to a lower one, say 20 so that you don't waste your server resources for nothing.

Can you please tell me why you told it would be a wastage of resources if campaigns at once is set to a higher number ? Does MW reserve/hold some resources as per this number forever ? My thought was like if this number is big, that many campaigns can run/start in parallel and resources will be used ONLY WHEN they're in process and there shouldn't be any problem as long as the server has enough juice to process that many campaigns. So, I don't think it's a waste of resources unless MW holds some resources solely for this forever.
 
@VVT - That used to be a problem in the past, now it isn't that much of a deal anymore, so it is safe to use higher values there.
 
  • Like
Reactions: VVT
Sorry I just replied this thread
I still get error...

1. I run /usr/bin/php -v
show php version is 5.3.3
2. mydomain.com/apps/console/console.php in the right location
3. campaign at once
just set to 20, 50, 100
still my campaign not sent
4. I tried to run /usr/bin/php -q /home/adm1n777/public_html/mydomain.com/apps/console/console.php send-campaigns >/dev/null 2>&1
on my console
there's no any report
i think it's success to run
but my campaign still not run
5. just information...
I had optin page with mailwizz in there
and just work!
single optin, double optin works

but for campaign NOT WORKS!

please what must I do now?
 
I just replied on tikcet support...
I tried campaign at once to 5, 20, 50, 100
and all .. campaign not sent
 
@darrendave - well, if you write same things on 10 different places, then i don't know what's for what and what goes where...
Please try to run this:
Code:
/usr/bin/php -q /home/adm1n777/public_html/mydomain.com/apps/console/console.php send-campaigns --verbose=1
 
@darrendave - it's fine, you seem to get a serious error there and we need to see what is that.
Go to backend > misc > application log and delete the log, then run the same command from command line and then return to the application log and refresh the page, you should now get there the same error you got in the console. Copy that and paste it here.
 
all working now...

but on application log I get this message...

2016/02/18 16:20:02 [error] [application] The PHP CLI binary is missing the IMAP extension!

what's that mean?
 
Looks like you're missing php-imap plugin which's used to access bounce/fbl mailboxes. Go to Miscellaneous > PHP info in admin dashboard and check if imap table is listed as in the attached image. If no, install the plugin by "yum install php-imap" (Centos) or "apt-get install php5-imap" (Ubuntu). In Ubuntu, you may have to manually enable it by "php5enmod imap" after the installation. Then restart apache, check the above page again and confirm imap is listed.
 

Attachments

  • imap.png
    imap.png
    7.9 KB · Views: 11
Ok... In the PHP Info, find "Loaded Configuration File" and open the php.ini in the server. Check if this line is active - "extension=imap.so" .
If commented out, uncomment it else add this line to the file. then reload apache and see if it works.
 
Back
Top