Embed Subscribe Page is Blank...


New Member
Anyway have this happening? In the quick links when I go to the EMBED forms page there is no code in the SUBSCRIBE box. There IS code in the UNSUBSCRIBE box and the IFRAME CODE box. This is not browser related...

Well I enabled php pntcl_exec and the embed form is showing up - whether that's the issue or not I have no idea
Well I enabled php pntcl_exec and the embed form is showing up - whether that's the issue or not I have no idea
check if
# all files are in place
# all permissions are correct
# mwz requirements checker bemoans something
# creating a new or copying a working list (one where the form code is present) helps
# another mwz instance of the same version on the same server has the same problem
Thanks for the reply - I'll run through this checklist (since again subscribe embed form not showing up) As well autoresponder campaigns don't go either although crons run and delivery servers are setup fine. Strange before did not have any of these issues but now do... more troubleshooting ....
Thanks for the reply, I control the server so if anyone changed anything affecting PHP it was me lol

It's odd that it shows the Unsubscribe embed code but not the Subscribe embed code.
Tried in browsers,phones, etc - same. Is there a way for me to check if all the PHP functions needed are there? Besides doing a complete reinstall?
Last edited:
Thank you that brings back the embed forms. Now I just have to figure out what broke my sending campaigns and autoresponders..... I had installed wordpress with some security apps so possibly that affected something as well as I had updated php, in any case I will try and figure it out.. Again thanks for the help.

EDIT: I changed the campaign after reading this below and my campaigns went. Will see if that was the solution....
Other reasons:
1) You try to run more campaigns than you actually allow from settings, so go to Backend -> Settings -> Cron and put 100 in the campaigns at once field, just as a test to see if it fixes your issue. If it does, lower this number to a lower one, say 20 so that you don’t waste your server resources for nothing.
Last edited:
Hi, I know this is an old topic, but I'm having the exact same problem.
I tried adding my IP and hostname in the hosts file like @twisted1919 suggested, but it's not working for me.
I still see the blank subscribe form
The strange part is I see the embed section and also the unsubscribe html.

Is there anywhere I can copy the html from?


  • 1.jpg
    32.9 KB · Views: 4
Yes, I have my own VPS. so I placed that IP, nevertheless, the box is still blank.

EDIT: I installed a brand new Mailwizz instance in the same server but with another URL, and the box is still blank.
The version is 2.1.19
Last edited:
Yes, I have my own VPS.
I assume you're familiar with command line in linux then.
Could you try to fetch the subscribe url from command line using curl:
curl https://www.your-subscribe-url.com....
You can paste here the output of that command, it will be a bunch of html.
You can also compare that HTML with what you see in the browser when you visit the subscribe page and hit the "View Source" option of your browser. My hunch is that, from your server, you'll get a totally different page.
Thanks for the reply @twisted1919
Unfortunately I'm unable to get the curl output

But I managed to modify the unsubscribe HTML and make it work for my needs!
Thanks again.
Thanks for the heads up!, I'll investigate that problem ASAP.

EDIT: In case someone has this same problem. I'm using a new Let's encrypt SLL, so I had to renew it and now everything works fine.
Last edited: