EMA isn't sending an mail at all from fresh install

Ben Griffiths

New Member
Hi,
I have purchase MailWizz and done a fresh install on my VPS which has all the requirements needed.
I have set up both SMTP and PHP Mail and still i'm not getting the valid server email come through.
I have gone through many things I thought it maybe, like sending from an email on the server already but I'm having no luck.

So far this is making my software unusable, any ideas what it could be?
 

Rob

Active Member
In 90% of cases this will be because your VPS host is blocking port 25. Check with them to see what their default settings are.
 

Kollydaton

Active Member
Try to liaise with your hosting provider to rectify the issue, as Rob as said above, it might be cause of port 25 or so been blocked , maybe relaying is now allowed on the server.

Liaise with your hosting provider to rectify the issue or better still port to another hosting if they do now allow relaying...

#Shalom ;)
 

Ben Griffiths

New Member
Hi thank you for your reply, port 25 is allowed, I already check this with my provider. I also tried port 2525 which is allowed. Relaying is allowed.

What's strange is php Mail doesn't work either. Which is one of the most simply configurations.

Also, wouldn't sending an email to verify the server just be a simple script that testing a the details?

The Cron jobs are all set up and working fine too just in case this is the issue.

Kind regards

Ben
 

Ben Griffiths

New Member
To add more information to what I have said.

I have tried both setting up a SMTP server and using standard PHP Mail.

I try to validate the server by entering a email to send the confirmation link to, after doing so I get no errors.

I get redirected to the server listed as programmed in the public function with the success message:

Please check your mailbox to confirm the server.

I check my mailbox and nothing has come through, I have also tried sending to multiple emails with different service providers such as gmail.com, hotmail.com and my own domain names. Still nothing.
 

Kollydaton

Active Member
@Ben Griffiths - It's true that the problem relies on somewhere else, Have you try using other email sender app on your current server? OR have you tried installing the mailwizz app on another server from another network?

Try this to know where the issue is peeping from:confused:

Thanks
 
Top