Do I have to set the .htaccess?

Charles Zuo

New Member
Hi everyone, do I have to set the .htaccess file? As I didn't find where to set it from "setting"---"common", version 1.3.5.2

I find my .htaccess file under root directory like below:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Please help me to confirm if it is okay? Or should I change it?
 

Rob

Active Member
Settings > Common Then you can choose to use Clean URLS, you need mod_rewrite installed to use them, then click Generate .htaccess. The system will generate the file and put it in your root folder.
 

twisted1919

Administrator
Staff member
@Charles Zuo - The .htaccess you have posted is generated by wordpress and applies only for wordpress.
For mailwizz, you can generate a new htaccess like @Rob mentioned above, or you can simply don't use clean urls at all, it's just a matter of preference in the end.
 

Charles Zuo

New Member
Thanks to Rob and twisted1919, good answers. Then I can ignore .htaccess now, since I don't care whether it is clean urls or not.
Sorry for my careless, the .htaccess I have posted belongs to my website...and I installed mailwizz in a
subdirectory.
 

Diego Reinoso

New Member
Hello,

I just made a change to use clean URLs. I did the process in the admin site, generated the .htaccess and it was generated without problems.

My site is working in this directory: /var/www/html/mail and the URL is http://keepkontact.tk/mail/

But now the site is not working at all, all request get a 404 response.

Please find attached the screenshot with the error and the htacces file (I changed it from .htaccess to htaccess.txt just to upload to this site).
 

Attachments

  • 2017-04-26 09_21_13-404 Not Found.png
    2017-04-26 09_21_13-404 Not Found.png
    24.7 KB · Views: 9
  • htaccess.txt
    2.4 KB · Views: 3

twisted1919

Administrator
Staff member
@Diego Reinoso - As i said in the support ticket, try to put index.php after the /backend/ in your url to reach the settings page and then disable clean urls.
Not sure why clean urls don't work for you, but since the app will work just fine without, you can disable them for now.
 
Top