Delivery server with Sparkpost's subaccounts

Zoltan

Member
Hi,

I would like to use SparkPost's subaccounts API key when I create a delivery sever and assign that server to a Client in MailWizz. But when I want to validate that server, there is an error message:

Cannot send the confirmation email using the data you provided,
  • Here is a transcript of the error message:
  • Forbidden.
I have no problem using SparkPost for the main account.

Could you take a look at this?

Thanks.
 

twisted1919

Administrator
Staff member
@Zoltan - Forbidden usually means the key you have generated does not have enough privileges for the api calls, so check the options you have checked/enabled when generated the api key.
 

Zoltan

Member
@twisted1919 Thanks. I checked the API permissions and all the options I can turn on for the subaccounts are checked:
Message Events: Read-only, Send via SMTP, Sending Domains: Read/Write, Suppression Lists: Read/Write, Transmissions: Read-only, Transmissions: Read/Write

For the main account, these are the permissions for the API:
Event Webhooks: Read-only, Event Webhooks: Read/Write, Inbound Domains: Read/Write, Message Events: Read-only, Metrics: Read-only, Recipient Lists: Read/Write, Relay Webhooks: Read-only, Relay Webhooks: Read/Write, Send via SMTP, Sending Domains: Read/Write, Suppression Lists: Read/Write, Templates: Preview, Templates: Read-only, Templates: Read/Write, Tracking Domains: Read-only, Tracking Domains: Read/Write, Transmissions: Read-only, Transmissions: Read/Write

So that means I can not create a delivery server with subaccounts?
 

twisted1919

Administrator
Staff member
@Zoltan - As far as mailwizz is concerned, it does not matter if it's a subaccount or a master account, it should just work if the api keys are correct.
I have also looked at https://github.com/SparkPost/php-sparkpost and it doesn't seem to have any special setting for subaccounts, only provide the right key and that's it, so i am not sure what to say related to this.
Maybe open a support ticket with them and ask them what's the deal?
 

Ahmed

Member
In spark post verify that your sending domain is set propery

I added mine with www. Which was not the correct way ( I was able to see this when I looked at the methods of verifying the domain - when I looked at the verify by email then the email looked like this abuse@www.mydomain.com )

I too Recieved the same forbidden error inside of mailwizz but then I added a new domain without www and it worked

Just give it a check to be sure it's not the same issue
 

twisted1919

Administrator
Staff member
@Vpul Shah - 302 means moved temporarily, so try to remove the delivery server from mailwizz, then in the webhooks area of sparkpost make sure you have none, then add the delivery server once again.
 

Vpul Shah

Well-Known Member
Ok. I have EC2 server webhook setup with other domain name.

So need to remove that ?

And if I removed that, then that server will work stop ?
 

twisted1919

Administrator
Staff member
If there's a webhook for another domain name/server id where mailwizz is active, then leave that like so, don't remove it because it will break the other app.

You should investigate more onto why you get that 302 status code on that server. maybe some htaccess or something is doing what it doesn't suppose to do;)
 

Zoltan

Member
@Vpul Shah No, it wasn't solved yet.
@twisted1919 : I have a problem with the SparkPost API (I guess). When I send it via SparkPost, the From email address is always the one, I gave for the delivery server, no matter what client account I send my emails from. (The Force FROM is set to never).

If I send the same from Mandrill, it uses the client's From email address.
Could you look into it?
Thanks.
 

twisted1919

Administrator
Staff member
@Zoltan - This is how it suppose to work since we cannot verify each sending address at sparkpost and make sure it is validated.
HOWEVER, from upcoming version, all delivery servers of type web api will have control over this aspect through the FORCE FROM setting. So if you verify your sending domain and set the Force FROM to never, and in your campaigns you send from any other verify email address, then will work just fine. BUT if you set the force from to never and send from a unverified email address, then sending will fail and mailwizz won't be able to do a thing about it. It's a tradeoff where i am giving you more power ;)
 

Zoltan

Member
That is great!
(Until this update, unfortunately I can not use SparkPost.)
Is there an ETA on the upcoming version? :)
 

Zoltan

Member
@Zoltan - As far as mailwizz is concerned, it does not matter if it's a subaccount or a master account, it should just work if the api keys are correct.
I have also looked at https://github.com/SparkPost/php-sparkpost and it doesn't seem to have any special setting for subaccounts, only provide the right key and that's it, so i am not sure what to say related to this.
Maybe open a support ticket with them and ask them what's the deal?

@twisted1919 I know it might be SparkPost's deal, but could you help me figure this out? I still can not make a delivery server with a subaccount API key. I am sure I'm not the only one facing this problem and it would be a great feature to use with MW. I contacted SparkPost, but no response at all.

Thank You.
 

frm.mwz

Well-Known Member
@twisted1919 I know it might be SparkPost's deal, but could you help me figure this out? I still can not make a delivery server with a subaccount API key. I am sure I'm not the only one facing this problem and it would be a great feature to use with MW. I contacted SparkPost, but no response at all.

Thank You.

it may depend on how you ask them...perhaps not as a 'mailer user', but rather as a 'crm transactional user'...just a thought ;)
 

Vpul Shah

Well-Known Member
@Zoltan :

When you create sub account and its api key, you have to give Permission/rights to allow send via API.

Check it and tell me it works or not.
 
Top