Delivery Server Error

rags810

Member
I have been getting the following error when I set up delivery server while I validate, http://prntscr.com/6jqc1x

  • Cannot send the confirmation email using the data you provided.
  • Here is a transcript of the error message:
  • Connection could not be established with host smtp.gmail.com [Connection timed out #110]
    Log data:
    ++ Starting Swift_SmtpTransport
    !! Connection could not be established with host smtp.gmail.com [Connection timed out #110]

I try to set up with one of my dedicated server site settings, I get same error. Now, I tested with gmail credentials, still the same error.

Gmail settings as shown here, http://prntscr.com/6jqdkb

Anyone knows what could be the issue.
 

Rob

Active Member
Do you have SSH access to your hosting environment? Or are you on shared hosting?

If you have SSH, login and telnet to smtp.gmail.com and see if it establishes a connection.
 

Rob

Active Member
What does it say in your application log? Backend > Miscellaneous > application Log
 

Rob

Active Member
Also try just leaving the protocol blank in the delivery server settings and try both 587 & 465. TLS is a preferred method BTW.
 

rags810

Member
OK, that's connecting. Now test using authentication, you can see how to do that here: http://stackoverflow.com/questions/1516754/connecting-to-smtp-gmail-com-via-command-line
I followed this and its working perfectly fine even with my login credentials.

If that works then double check your credentials you have input into MW.
My gmail's login credentials are just fine.

Also try just leaving the protocol blank in the delivery server settings and try both 587 & 465. TLS is a preferred method BTW.
I tried with all options, its still giving me the same error as per my first post.

I don't know what is the issue.
 

Rob

Active Member
Try a different smtp via telnet:

telnet smtp.sendgrid.net 25
Trying 5.153.47.203...
Connected to smtp.sendgrid.net.
Escape character is '^]'.
220 ismtpd-042 ESMTP service ready
 

rags810

Member
Tried,

Result as follow:

telnet smtp.sendgrid.net 25
Trying 198.37.144.225...
Connected to smtp.sendgrid.net.
Escape character is '^]'.
220 ismtpd-090 ESMTP service ready
 

Rob

Active Member
Who do you host with?
Are you sing the latest MW version 1.3.5.2?

I would temporarily switch off iptables quickly check the server connection from within MW and see what happens.

If that works switch iptables back on then add this rule:

iptables -I INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT

The way this rule works is that when your system makes an outbound connection, the kernel records the connection in a tracking table. Then when packets from the remote system come back in, it looks to see if those packets are associated with any connections in the tracking table.
The ESTABLISHED bit is the one that allows traffic directly related to the session. This will be TCP packets coming back on the stream.
The RELATED bit lets traffic that's related to the connection, but isn't part of the connection itself, through. This can be things like ICMP packets, such as "ICMP can't fragment". These packets aren't part of the TCP stream, but are vitally important to keeping the stream alive
 

rags810

Member
I host with directi (resellerclub)

Yes, I am using the latest version 1.3.5.2

Turning off configserver firewall did the trick.

iptables -I INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
What is the code to reverse in case if I have to?
 

Rob

Active Member
Glad you fixed it.

To remove: iptables -D INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT

But if you are using configserver firewall this rule may not work (or will work but not controlled from configserver). I'm not familiar with it so you might have to search for how to implement that rule via configserver.

What you need to ensure is that you don't allow ports 465 & 587 inbound and open to all, otherwise your server will be used to spam the world :)
 

rags810

Member
Sure, will speak with my host on this and get it resolved.

Thanks a ton for your time and really appreciate...
 
Top