custom tracking domain error

emailwrks

Member
hey,

i have set a custom tracking domain in mailwizz and set the CNAME record so it points to my mailwizz domain

have now left it for 24hrs to allow for any propogation, on my test emails now, clicking a link just results in a 404 error on that tracking domain

what have i missed?

thanks, J
 

twisted1919

Administrator
Staff member
Do you have a dedicated ip address for your domain?
When you access your tracking domain in broswer, do you see same content as you see when accessing the domain where mailwizz is installed? If you don't, then the answer is simple, you don't have a dedicated ip address for your domain where mailwizz is installed.
 

emailwrks

Member
Yes I have a dedicated ip for the domain

I have pointed the cname for the sub domain to the mailwizz domain only so far as per instructions, in the records

So far just still the 404 error. Is there an A record I need to put the ip in instead?

Thanks
 

twisted1919

Administrator
Staff member
No need for A record.
What is the domain name where mailwizz is installed and what's the tracking domain?
 

twisted1919

Administrator
Staff member
I am not sure how to explain this better, and i am not that familiar with cpanel inner workings, but i am not reffering at the hostname, but rather at the default domain that is set for that ip address.
Basically you have 2 virtual hosts now, 1 that is loaded when you access ewrxplatform.me and another one that is a wildcard virtualhost which gets loaded anytime when your ip or any other hostname pointing to your is loaded. You need to get rid of the second one so that the first one remains the only virtual host.
I am not sure how to explain this better :D
 

emailwrks

Member
well ive had a look at this and truth be told i'm not 100% in what i'm doing to make any changes

Wondering if i could have solved it with these things i found below;

WHM > networking setup > hostname is set to "mail.ewrxplatform.me". But the hostname of the domain also is set in the account functions correctly to ewrxplatform.me

cpanel, no addon domain is set at all, is blank. So this could be referencing the IP issue?

thanks
 

twisted1919

Administrator
Staff member
WHM > networking setup > hostname is set to "mail.ewrxplatform.me". But the hostname of the domain also is set in the account functions correctly to ewrxplatform.me
I don't think you have to change this at all, don't play here.

cpanel, no addon domain is set at all, is blank. So this could be referencing the IP issue?
I honestly don't know, as i said, i am not that familiar with whm/cpanel since i am more of a command line guy.
 

jp1981

New Member
hey,

i have set a custom tracking domain in mailwizz and set the CNAME record so it points to my mailwizz domain

have now left it for 24hrs to allow for any propogation, on my test emails now, clicking a link just results in a 404 error on that tracking domain

what have i missed?

thanks, J

How did you add it? Via cPanel or WHM?
Have you included a dot after the domain name under CNAME?

track.yourdomain.com 14000 IN CNAME mailwizzdomain.com.
 

emailwrks

Member
I added the tracking domain in another cpanel I control, cname to point to mailwizz domain.

I will have to check about the dot, but may be auto added though

In the mailwizz platform domain, I have whm and cpanel on this server, and have not taken any steps to reference the tracking domain there
 

emailwrks

Member
okay adding a dot makes it not a valid zone etc

put in a cpanel ticket to see if they can help me
But otherwise not been able to sort this as yet

thanks, J
 

emailwrks

Member
hey,

i still have not been able to rectify this in any easy way.

in terms the 2nd virtual host IP being a problem, the guys at cpanel seem to think getting rid of the A records set at linode will help the problem. But im not sure i want to do this

what can i do command line to maybe try fix it?


thanks, J
 

Eldi

Member
OK
This will happen to everyone soon lol after whm update.

Problem is that tracking domain redirects to default document root of the server.

Steps to fix this are: open httpd.conf in the mailzizz server (default location is: /usr/local/apache/conf)

Find there DocumentRoot path of the server and replace with /home/yourusernameofmailwizzdomain/public_html

There are 2 places containing this:

Mine looks:

<VirtualHost server IP>
and
<VirtualHost *>

This both paths have the default location which must be pointing in your case here: cgi-sys/defaultwebpage.cgi

Just replace them with default path of your mailwizz domain path. You can find the exact path below this lines where are the rows of config for your mailwizz domain.


Sorry for my english but this is the only solution for the moment. Dont forget to backup the file before editing.
After editing and saving restart apache. ( service httpd restart ) or restart from whm.

But but but anytime whm will be updated you will loose this modification. (and this will happen almost everyday even though i tried to not update whm from whm settings)

Solution for this is to this command that prevents edit of httpd.conf from whm update

Simply set the attribute for the httpd.conf file with the below command

chattr +i /usr/local/apache/conf/httpd.conf

Nothing will be changed in the conf file unless attribute is removed. To remove the attribute use,

chattr -i /usr/local/apache/conf/httpd.conf


You must remove this attribute when adding or removing accounts from whm.
 

emailwrks

Member
thanks for the above update, really helpful in trying to troubleshoot this.

However i have managed to sort this another way for now after chatting to people half of today :\

In cpanel I have simply added the tracking domain as a parked domain only. It is not added to cpanel or WHM in any other way, just added as a parked domain, and from live testing just now that seems to have worked a treat.

Just in case the above happens on updates, i have turned off all automatic updates in WHM. Might revisit that one for testing at least

thanks all for the help given, hopefully someone else will find this useful at some point
 
Top