Can't set the delivery/bounce servers

Arda

New Member
Hello everyone,

I am using Digital Ocean as my host. My machine is a Ubuntu 14.04 and has PHP 5.6.14 and OpenSSL 1.0.1f installed.

Registered Stream Socket Transports are: tcp, udp, unix, udg, ssl, sslv3, tls, tlsv1.0, tlsv1.1, tlsv1.2

I have followed this tutorial exactly (some options have changed on Amazon's part):

I tried contacting DigitalOcean but they also couldn't help me with this problem. My server says "command not found" when I try to enter "apt-get install php-imap".


I am getting this error when I try to verify my email in the Delivery Server Setup page:

Cannot send the confirmation email using the data you provided
Here is a transcript of the error message:
Failed to authenticate on SMTP server with username "xxx" using 2 possible authenticators

I am getting this error when I try to put my bounce server:

Your form has a few errors, please fix them and try again!
The IMAP extension is missing from your PHP installation. (For Hostname)

I researched on Google ways to fix my issues. I tried everything but it didn't work. I have also contacted DigitalOcean and told them about the issue.

I need help.

Thanks.
 

twisted1919

Administrator
Staff member
Hey @Arda -
Have you tried apt-get install php5-imap for the missing imap extension?

For the smtp issue related to using 2 authenticators, if those streams are registered i really don't see the reason of failure.
You might wanna change between the mailers from backend -> settings -> common and try with phpmailer too.
However, given the fact we're talking about amazon here, use the web api implementation when creating a delivery server, that is, instead of amazon smtp.

Give those a try and see where you're at ;)
 

Arda

New Member
Now i see you said when you run apt-get you get a command not found instead.
apt-get is the package manager for ubuntu, not having this is sign of some other serious issue.
See http://ubuntuforums.org/showthread.php?t=1922436 and then if you fix it http://serverfault.com/questions/173443/how-do-i-enable-the-imap-functions-in-php

Hey man thank you for your fast reply.

I have somehow managed to update the php5-imap but i am still getting the error that i got before. Nothing has changed.

When I try to use PHPMailer, I get this error below:

Here is a transcript of the error message
SMTP connect() failed.
CLIENT -> SERVER: EHLO theardasozen.tk
CLIENT -> SERVER: AUTH LOGIN
SMTP ERROR: AUTH command failed: 530 Must issue a STARTTLS command first
CLIENT -> SERVER: QUIT

UPDATE - added a bounce and feedlack loop server successfully. The delivery server still doesn't work. Opened new users with, tried both PHPMailer and SwiftMailer, none of them worked.

What should I do?
 
Last edited:

twisted1919

Administrator
Staff member
Code:
CLIENT -> SERVER: EHLO theardasozen.tk
CLIENT -> SERVER: AUTH LOGIN
SMTP ERROR: AUTH command failed: 530 Must issue a STARTTLS command first
CLIENT -> SERVER: QUIT
This means you had to use TLS as the connection protocol from the server setup page, did you use it ?
 

Arda

New Member
Code:
CLIENT -> SERVER: EHLO theardasozen.tk
CLIENT -> SERVER: AUTH LOGIN
SMTP ERROR: AUTH command failed: 530 Must issue a STARTTLS command first
CLIENT -> SERVER: QUIT
This means you had to use TLS as the connection protocol from the server setup page, did you use it ?
Yes, I have just tried using TLS as my connection protocol but it did not work again.

I am going to lose my mind. What should I do?
 

twisted1919

Administrator
Staff member
@Arda - Whatever you do, don't lose it ;)
PM me with your smtp server details so that i can try them on my end and see if the problem is just on your server or not.
 

twisted1919

Administrator
Staff member
From your MT link, your biggest issue is the Sender ID. Sender ID is like SPF, but it checks the FROM address, not the bounce address.
So, you could edit your SPF records for the domain michaelblatt.com which right now should be:
Code:
v=spf1 a mx ptr include:secureserver.net ~all
and make it:
Code:
v=spf1 a mx ptr include:secureserver.net include:amazonses.com ip4:54.240.27.45 ~all
See http://www.spfwizard.net/ for more details about spf.
And that should fix it (give it few hours for dns propagation)

Your second issue is that the amazon ip is blacklisted in a blacklist, but you can't really do much about it just to wait for it to be delisted.

That's pretty much it. Try the SPF update and see if that makes any difference.
 

Arda

New Member
From your MT link, your biggest issue is the Sender ID. Sender ID is like SPF, but it checks the FROM address, not the bounce address.
So, you could edit your SPF records for the domain michaelblatt.com which right now should be:
Code:
v=spf1 a mx ptr include:secureserver.net ~all
and make it:
Code:
v=spf1 a mx ptr include:secureserver.net include:amazonses.com ip4:54.240.27.45 ~all
See http://www.spfwizard.net/ for more details about spf.
And that should fix it (give it few hours for dns propagation)

Your second issue is that the amazon ip is blacklisted in a blacklist, but you can't really do much about it just to wait for it to be delisted.

That's pretty much it. Try the SPF update and see if that makes any difference.

Hey man, I just changed my settings and my score went to 7.5 instantly!!

http://www.mail-tester.com/web-k1FkSj
 

twisted1919

Administrator
Staff member
As expected i would say. however, i'd recommend you still wait 24 hours for dns propagation and while you wait, maybe the blacklist issue will go away too ;)
 
To solve your problem, you have to fix your SPF record.

This is your current record.

"v=spf1 a mx ptr include:secureserver.net include:amazonses.com ip4:54.240.27.45 ~all"

The A, ip4:xxx.xxx.xxx.xxx & PTR records above are unnecessary.

Try with the the record below.

"v=spf1 mx include:amazonses.com include:secureserver.net ~all"

It can be shortened even more if you are never going to send through your MX (mail.michaelblatt.co) or GoDaddy's mail servers (secureserver.net).

=====

Good article explaining the hazard of too many DNS lookups.

http://www.onlineaspect.com/2009/03/20/too-many-dns-lookups-in-an-spf-record/
 
Last edited:

twisted1919

Administrator
Staff member
@Georgie - If mailwizz says the extension is missing it means it cannot find it, so maybe after you have ran apt-get install php5-imap you also have to enable it in php.ini.
 
Top