Cant add Mailgun delivery server

Sarunas

New Member
Created Mailgun account, activated account and domain dns records.
got api
Added devivery server and cant activate, error:
  • Cannot send the confirmation email using the data you provided.
  • Here is a transcript of the error message:
  • Cannot create the spam webhook
 

twisted1919

Administrator
Staff member
Hi,

I assume we are talking about the web api integration, right ?
Any specific error in the mailgun dashboard ?
Do you have any firewall or htaccess that can prevent remote connections from outside to your website?

Lemme know.
 

Howard

Member
Hello,

have you resolve this issue? i also got this error when adding mailgun API
the error only says:

  • Cannot create the spam webhook!
but when i check webhooks in the mailgun admin the value in the spam webhook exist.

Thanks
 

Sebastian

Member
I had the same problem and I solved this way, but first here's my configuration:
  1. MW is installed in a subdomain (app.mydomain.com)
  2. In Mailgun I ONLY validated the main domain: mydomain.com
To solve the problem you must set the "Wildcard Domain" option (under Domain Settings) to ON.
It should work now :)
 

Moostach

New Member
With a new version of MW I have the same problem here, I can't validate my delivery server with mailgun API :
- mailgun domain is activated
- the API key is correct
- mailgun SMTP works fine
- all the domains used are configured with Cloudflare
Thanks by advance
 

Moostach

New Member
Specific error :
  • Cannot send the confirmation email using the data you provided.
  • Here is a transcript of the error message:
  • Cannot create the spam webhook!
Does it work w/ cloudflare ?
No, I desactivated Cloudflare and purge but it's the same error.
I tested with a domain which is not on Cloudflare, it's the same error.

Thanks
 

twisted1919

Administrator
Staff member
Well that says that it can't create the webhook and since webhooks in mailgun are domain dependent, what domain did you add in mailwizz? Is that domain verified ?
i am asking because i have just tried and it works for me.
 

Moostach

New Member
All the domains are verified on mailgun, they are noticed as active in my dashboard.
I haven't any mention on dashboard or in domains tab for unverified or other indications like that.
 

twisted1919

Administrator
Staff member
You still did not answer my question, in mailwizz, in the domain field when creating the delivery server, do you use a domain that is verified in mailgun ?
 

twisted1919

Administrator
Staff member
I see, this makes it weird, mainly because i can't replicate this on my end. If anyone with same issue can chip in would help, otherwise i am not sure what exactly should i tell you to do.
 

Moostach

New Member
I tried to :
- renew the api key
- create and validate new domain
- create and validate a new subdomain
The same problem again in mailwizz backend.
 
Top