Campaigns recently having Connection refused #111] (code: 0) error

jhall95

New Member
It's only started recently while warming up my server but i try and send around 150 emails, half will send successfully then the other half will get:

Connection could not be established with host 62.171.xxx.xxx [Connection refused #111] Log data: ++ Starting Swift_SmtpTransport !! Connection could not be established with host 62.171.xxx.xxx [Connection refused #111] (code: 0)

I tried lowering my delivery settings so it's trying to send less in one go but doesn't seem to have helped much.
1598368604443.png

Also I have retry failed sending is on but I've not noticed any additional emails being sent after failure.

Any advice on this?
 
Last edited:

laurentiu

Active Member
Staff member Support Staff
@jhall95 - connection refused means that the smtp server is refusing your connection. This is a setting issue of your delivery server or your server is not allowing outgoing connections. Please contact your hosting and ask them to allow outgoing connections.
 

jhall95

New Member
@jhall95 - connection refused means that the smtp server is refusing your connection. This is a setting issue of your delivery server or your server is not allowing outgoing connections. Please contact your hosting and ask them to allow outgoing connections.
Thanks I have reached out to them on that. Any idea why I'm not getting any attempted retries after they fail though even with the setting turned on?
 

ghimes

Member
Staff member Support Staff
Any idea why I'm not getting any attempted retries after they fail though even with the setting turned on?
That settings is saying that the email will be marked with the status GiveUp and then mailwizz will retry it 3 times. Why are you saying that is not retried?

Cosmin
 

jhall95

New Member
@ghimes

I was expecting the emails stuck not sending would retry every hour, not immediately try 3 times but I was mistaken.

I've also changed my settings to send 5 emails every 20 seconds but when I upload I can see in the campaign delivery logs they are tried all at once and so many of them are failing. Can you help me out with that?

1598524449854.png
 
Last edited:

jhall95

New Member
Also is it possible to start resending all the emails that are stuck in GiveUp. I can't see any way to export the logs to get a list of who has not been sent an email
 

ghimes

Member
Staff member Support Staff
've also changed my settings to send 5 emails every 20 seconds but when I upload I can see in the campaign delivery logs they are tried all at once and so many of them are failing. Can you help me out with that?
The way you set it it sends a batch of 5 subscribers at once and then pause for 20 seconds. So the behaviour is expected.

Also is it possible to start resending all the emails that are stuck in GiveUp. I can't see any way to export the logs to get a list of who has not been sent an email
In the Customer area in the campaigns list, there is a button for resending GiveUps for each campaign that has the status Sent.

Cosmin
 

jhall95

New Member
The way you set it it sends a batch of 5 subscribers at once and then pause for 20 seconds. So the behaviour is expected.


In the Customer area in the campaigns list, there is a button for resending GiveUps for each campaign that has the status Sent.

Cosmin
I know that's what it should do but what I've witnessed is I will upload 200 subscribers, there will be 200 logs straight away in the campaign delivery logs instead of 5 every 20 seconds
 

jhall95

New Member
I also do not see a button to resend but I can see there's a way to export all the failed so I can try and reupload to resend

1598608897734.png
 

ghimes

Member
Staff member Support Staff
I know that's what it should do but what I've witnessed is I will upload 200 subscribers, there will be 200 logs straight away in the campaign delivery logs instead of 5 every 20 seconds
Let us investigate this...

I also do not see a button to resend but I can see there's a way to export all the failed so I can try and reupload to resend

View attachment 11158
The status of the campaign needs to be Sent to be able to see that button.

Cosmin
 

twisted1919

Administrator
Staff member
I know that's what it should do but what I've witnessed is I will upload 200 subscribers, there will be 200 logs straight away in the campaign delivery logs instead of 5 every 20 seconds
You should put the limitation on the delivery server directly, we will be removing this setting from the app in version 2.0 because it doesn't do a thing for a while now.
The status of the campaign needs to be Sent to be able to see that button.
And you also need to enable the ability to resend to giveups, don't forget that.
 

jhall95

New Member
You should put the limitation on the delivery server directly, we will be removing this setting from the app in version 2.0 because it doesn't do a thing for a while now.
Right ok. A bit of a stretch but do you or your colleagues know how to add a minute limit in Postal. Can't find it in their documentation.

And you also need to enable the ability to resend to giveups, don't forget that.
I've got "retry failed sendings" enabled in the CRON settings. Is there somewhere else I need to enable it for giveups specifically? I had changed my campaign yesterday to send after 1 day at 11:00 UTC and then uploaded some users, that time has gone past but there's still no button to send, no actual emails were sent at all but that's a different problem
 

ghimes

Member
Staff member Support Staff
Right ok. A bit of a stretch but do you or your colleagues know how to add a minute limit in Postal. Can't find it in their documentation.
The limitation should be put from Mailwizz->Backend->Delivery Servers->Edit Server-> Hourly Quota is the lowest time unit.

Cosmin
 

jhall95

New Member
Thanks for all the advice. A combination of the Hourly quota as well as the pause after sending setting on the delivery server itself spaces out the emails so my SMTP does not get overworked

1598630189518.png
 
Top