Campaign Sending Issue

AHK

Active Member
Hello,
I am running 1.3.8.5 version and i am facing strange issue.
like if i am sending one email campaign of 150K subscribers and in sending if SMTP server start returning errors like my server network was down and i was getting lot of errors every 10 min one error.
at end of campaign when campaign finish and i saw campaign report it show me Recipients 57,903
but campaign was 150K why it send to 57K ?
if some emails are not send it should try later or at end of campaign.
is there any setting which i am doing wrong or how to fix this?

Thanks
 

twisted1919

Administrator
Staff member
I am running 1.3.8.5 version and i am facing strange issue.
You should upgrade to latest version ;)

150K subscribers and in sending if SMTP server start returning errors like my server network was down and i was getting lot of errors every 10 min one error.
It's your job to make sure you have good sending server, mailwizz cannot do magic.

at end of campaign when campaign finish and i saw campaign report it show me Recipients 57,903
but campaign was 150K why it send to 57K ?
It only shows you the recipients, that is, the ones who got your email without issues, where the server didn't show any error.
if some emails are not send it should try later or at end of campaign.
We used to retry but it puts to much weight on mailwizz, so we pass this responsability to the mta. A good mta will accept all emails and will handle retries.
 

frm.mwz

Well-Known Member
We used to retry

It would be much appreciated, probly by many, if this could be a feature one can enable
either generally for the whole app or
on a per customer / delivery server / campaign basis.

Also, if one could easily select the GiveUps and put them up for re-sending, that would help a lot too.

Not being able to deal with the GiveUps effectively is definitely a feature loss.

When was that taken out (could not find it in the ChangeLog)?
 

AHK

Active Member
@twisted1919
this is really strange cause this is causing issue for customers and for me. there could be 1000s of reasons why SMTP server did't accept messages like
1. Daily or monthly quota on Sparkpost exceed
2. Elastic mail suspend account
3. my MTA server network goes down for 30 min
4. how man reasons i can tell .... there can be many many reasons...

and its strange that if mailwizz did't wait to send all messages in QUE and make campaign send.

now my customer told me he send 150K emails and only 57K emails were send , where is 100K emails which was not send ?
how can i send them again after fixing SMTP server issue ?
if i send campaign again 57K subscribers will receive double emails :(
if i don't send campaign 100K subscribers did't receive my email :(

now i have no idea how to send email to missing 100K subscribers which mailwizz skip, i don't mind campaign to wait 2 days in sending until it send email to each and every subscriber in list.

could you please tell me how to fix this ASP as this is creating issues on daily basis
or tell me version of Mailwizz and i will go back to that version, i don't need updated version which is now creating this big issue.

Thanks
 

AHK

Active Member
@twisted1919 @frm.mwz
as i was running into this issue and i have created a small extension to help you.

here is extension. feel free to use & update it and let me know if you make it more useful.
This extension will add one button next to campaigns and if you see that some campaign was not send to all subscribers for some reason, you can click on this icon and this will start completed campaign again and send emails to all missing subscribers.
thanks @twisted1919 for all help :)

thanks
 

Attachments

  • resend.zip
    16.7 KB · Views: 20

frm.mwz

Well-Known Member
@twisted1919 @frm.mwz
as i was running into this issue and i have created a small extension to help you.

here is extension. feel free to use & update it and let me know if you make it more useful.
This extension will add one button next to campaigns and if you see that some campaign was not send to all subscribers for some reason, you can click on this icon and this will start completed campaign again and send emails to all missing subscribers.
thanks @twisted1919 for all help :)

thanks
Extension uploaded, enabled, gone into all camp view and specific camp view,
in earlier and latest version, but cannot find that button. Please help, thx :)
 

AHK

Active Member
its working fine with me.
i even test in latest version and its working perfect.
you will see button in admin campaign->index page, first button near pause, block, delete campaign.
for customer also in campaign->index page, first button near pause, block, delete campaign.
but if you open extension file, there is option to set true or false for customer.
please share screen if you still have issue.
thanks
 

Osjtya

Active Member
MailWizz 2.0 Tester
@frm.mwz, will be looking for your test results :D

@AHK, Thanks for the amazing contribution to the community and MailWizz :)

Is there a way with your extension that we can enable it for some particular customer group not for all?
 

frm.mwz

Well-Known Member
@frm.mwz, will be looking for your test results :D

@AHK, Thanks for the amazing contribution to the community and MailWizz :)

Is there a way with your extension that we can enable it for some particular customer group not for all?
Tested on three campaigns with various amounts of "GiveUps".
All worked-off perfectly.
Great!
:)
 

frm.mwz

Well-Known Member
@AHK, Great news it's working perfectly as per @frm.mwz test results ;)

Now once you're free I'll be looking for updated version :D Thanks
While you are at it @AHK maybe you could have a look into other delivery errors that might be worthwhile to take care of selectively (error, temp-error, fatal-error, etc)? But really, only down the road, if convenient for you. This as it is, is great! Thx again :)
 

Papapooch

Member
@AHK I installed the extension and do not see the Resend button in Campaigns index. When you say:
"if you open extension file, there is option to set true or false for customer"
What does that mean Open Extension File???
In the extensions listing I do not see an Update or Configure button. Do I actually have to open a File and mess with the code?
Thanks
 
Top