Bounce email goes into X-Sender: bounce@email.com

Discussion in 'General discussions' started by ipolic, Jun 16, 2017.

  1. ipolic

    ipolic Member

    Joined:
    Jun 14, 2016
    Messages:
    89
    Likes Received:
    9
    S.E:
    Expired
    L.T:
    Regular
    L.C:
    1
    Hi there, I have problem and I hope solution is simple.

    I added bounce server and now I see it in x-sender, from what I understand it should be added to return-path and maybe some other places. x-sender should be FROM email from what I understand.

    Can you please help me out how to have normal, good headers as they should be with bounce@domain.com in normal position/tag ?

    Thank you!
     
  2. ipolic

    ipolic Member

    Joined:
    Jun 14, 2016
    Messages:
    89
    Likes Received:
    9
    S.E:
    Expired
    L.T:
    Regular
    L.C:
    1
    If someone has issue like this, solution is VERY simple, just replace phpmailer with swiftmailer in backend/settings/common/Default system mailer *
     
  3. frm.mwz

    frm.mwz Well-Known Member

    Joined:
    Mar 8, 2016
    Messages:
    3,481
    Likes Received:
    650
    S.E:
    2019-05-17 04:02:46
    L.T:
    Regular
    L.C:
    7
    Ideally you have FROM = ReplyTo = ReturnPath, since receiving servers decide anyway mostly as they wish these days, and filters don't like it to be multiple addresses (and are likely to flag it/sort it out). Good old-fashioned consistency inboxes best ;)

    PS: Forgot to add: PhpMailer is about 2.6x faster than SwiftMailer from my tests.
     
  4. ipolic

    ipolic Member

    Joined:
    Jun 14, 2016
    Messages:
    89
    Likes Received:
    9
    S.E:
    Expired
    L.T:
    Regular
    L.C:
    1
    Thnx!
     
  5. fair-point

    fair-point New Member

    Joined:
    Jun 12, 2018
    Messages:
    2
    Likes Received:
    0
    S.E:
    2019-03-14 01:03:35
    L.T:
    Regular
    L.C:
    2

Share This Page