Automatic Updates Stopped

Dilbert

Member
Back in January I see I had an automatic update. There were a few before that too.
Here are my crons from the admin section

DescriptionCronjob
Campaigns sender, runs each minute.* * * * * /opt/cpanel/ea-php74/root/usr/bin/php -q /home/pathlabt/public_html/newsletter/apps/console/console.php send-campaigns >/dev/null 2>&1
Transactional email sender, runs once at 2 minutes.*/2 * * * * /opt/cpanel/ea-php74/root/usr/bin/php -q /home/pathlabt/public_html/newsletter/apps/console/console.php send-transactional-emails >/dev/null 2>&1
Bounce handler, runs once at 10 minutes.*/10 * * * * /opt/cpanel/ea-php74/root/usr/bin/php -q /home/pathlabt/public_html/newsletter/apps/console/console.php bounce-handler >/dev/null 2>&1
Feedback loop handler, runs once at 20 minutes.*/20 * * * * /opt/cpanel/ea-php74/root/usr/bin/php -q /home/pathlabt/public_html/newsletter/apps/console/console.php feedback-loop-handler >/dev/null 2>&1
Delivery/Bounce processor, runs once at 3 minutes.*/3 * * * * /opt/cpanel/ea-php74/root/usr/bin/php -q /home/pathlabt/public_html/newsletter/apps/console/console.php process-delivery-and-bounce-log >/dev/null 2>&1
Various tasks, runs each hour.0 * * * * /opt/cpanel/ea-php74/root/usr/bin/php -q /home/pathlabt/public_html/newsletter/apps/console/console.php hourly >/dev/null 2>&1
Daily cleaner, runs once a day.0 0 * * * /opt/cpanel/ea-php74/root/usr/bin/php -q /home/pathlabt/public_html/newsletter/apps/console/console.php daily >/dev/null 2>&1

Here are the crons listed in cPanel.

1619697994386.png

Am I missing some? I haven't made any changes since the last time it ran in January.

Thank you
 

twisted1919

Administrator
Staff member
Try to run this from command line:
Code:
/usr/local/bin/ea-php70 -q /home/pathlabt/public_html/newsletter/apps/console/console.php auto-update --verbose=1
What do you get?
 

Dilbert

Member
Thank you for your quick reply.

Oddly, I have not changed anything, so not sure why it's not updating now.

cPanel-Terminal.png
 

twisted1919

Administrator
Staff member
The error message is pretty clear, your hosting has disabled the exec function. Enable it and the auto-update will work.
 

Dilbert

Member
The error message is pretty clear, your hosting has disabled the exec function. Enable it and the auto-update will work.
Thanks, I guess I was wrong when I said there were no changes. I've read leaving that turned on could allow malicious scripts to be run so I turned it off.
Thanks for helping, but I'll stick to manual updates.
 
Top