Amazon SES bounce rate vs. MailWizz bounce rate...

Kevin Madison

New Member
We were recently shut down by Amazon due to a high bounce rate that we failed to notice in time because the MailWizz reported bounce rate seemed fine while Amazon is saying we had a much higher bounce rate. Our delivery servers are setup as "Amazon Ses Web Api" which I believe should process bounces?

Here is what MailWizz is showing for our recent campaigns:

Campaigns 2020-08-10 08-39-16.png

On July 26, Amazon opened a support ticket with this information noted:

Your current bounce rate is 10.35%. We measured this rate over the last 273,068 eligible emails you sent. Our analysis covers the last 2 days.*

On July 31, Amazon opened another support ticket with this information noted:

Your current bounce rate is 16.82%. We measured this rate over the last 239,342 eligible emails you sent. Our analysis covers the last 6.9 days.*

Just wondering if anyone has any ideas about why MailWizz's reported bounces would be so much lower than what Amazon is seeing?
 

Vpul Shah

Active Member
Hello Kevin,

In your screenshot, it shows aprox 8000 Hard bounce in your 6 campaigns.

So can you check with other campaigns and see bounce numbers.
 

Kevin Madison

New Member
Hey Vpul, thanks for the response.

In the screenshot you'll see that the total delivered emails is around 650,000, so < 2% bounce rate. Amazon said they measured 16.82% bounce rate over the last 239,342 emails over the last 6.9 days (July 24 onward).
 

twisted1919

Administrator
Staff member
@Kevin Madison - as far as we're concerned, if you get a single bounce, then it means bounce processing works for you.
We process all the events amazon sends to the SNS topic mailwizz is registered to receive, so as far as that endpoint on your server is reachable, there should be no problems.
You should ask for a more detailed response from them, like they should tell you from that number of bounces they recorded, how many did they actually sent to the sns topic, and how many of those were received successfully, etc, you need to have the whole picture, not just some numbers.
 

Kevin Madison

New Member
@twisted1919 Thanks for the follow up.... I just dig a bit of digging around the SES/SNS and I think I may have found something wrong.

We have 2 email addresses registered but only 1 of them has a registered SNS Topic:

Monosnap 2020-08-12 07-55-45.png

Under SNS I see two topics:

Simple Notification Service 2020-08-12 07-57-40.png

I have 2 Delivery Servers setup in MailWhizz so it looks like 1 of them isn't subscribed. Any idea how that could happen? I can hook it back up but it might be nice to figure out why it got disconnected in the first place.
 

twisted1919

Administrator
Staff member
I don't know the exact reason it might be a failed http request to confirm the sns topic subscription.
Can you try to add the server once again and see if this time it will do the connection?
 

twisted1919

Administrator
Staff member
Try removing the server (remove the sns as well if the app doesn't do it) and add it again.
Also, make sure your PHP version is > 7.0
Also, make sure the url in the above endpoint is accessible by anyone.
 
Top