Amazon SES authentication issue


New Member

I have created amazon credentials. I verified my email address. used as hostname. I used TLS as well. Tried all ports (25, 465, 587)
Still I get this error when I Validate server:

  • Failed to authenticate on SMTP server with username "********" using 2 possible authenticators

Please help me to add Amazon SES smtp server.

@Vpul Shah: do you mean multi factor authentication? No it is not active. Also I am using AIM user with AmazonSesSendingAccess Permissions.

@Rob I read those docs already. I followed all instructions.
Last edited:
OK, there are one or two things that can cause that error.

Check to see that your server has the port open you want to use.

Check to see you have SSL support in your PHP installation.

Test another SMTP service such as gmail to see if you receive the same issue. If you don't then it will be your credentials, if you do it may be one of the above.
Ok i checked for port 25 and 465 using "netstat -an | grep 465" command it showed me LISTEN
I also checked OpenSSL it is installed with version : 1.0.1e-fips

I tried to add gmail smtp but it also showed auth error. I can add mandrill service easily.
I tried amazon SES web api and got following output as shown in image I attached.

This is how I used credentials.
I went to smtp settings in SES. then i clicked create credentials. After I created credentials I used SMTP username and SMTP password in mailwizz. I used Amazon SES web api implementation. I used hostname as provided in smtp settings.


  • ses.PNG
    72.5 KB · Views: 43
I had some problems too, the installation was overall pretty easy (easier than sendy), it's only that there was no good tutorial on how to add the sending servers and when adding the amazon ses account I got confused because I didn't know which one was the "Amazon SES password" that was asked when adding a delivery server. I followed the instructions on the video and used the "Secret access key" and it worked. I suggest that you make it more clear of what information needs to be used. Like I said, so far this seems more friendly than Sendy (that's what we were using) but one thing Sendy had was easy to follow step by step tutorials.

I gave Access Key ID as username and Secret Access Key as password and got following error while validating server

  • Unable to determine service/operation name to be authorized

Oh for the hostname I gave the SMTP settings servername as

or what should we put there??
It's the same for either. The issue is likely to be the fact for the web api you need to create different credentials in the AWS console. You can't use the same as the SMTP server credentials. Did you watch the video above?
I have setup Amazon SMTP now using the same credentials and while validating server it didn't return any error but I haven't recieved any email either so would wait for few minutes/hours and would post the results here..

I did the same thing as in the video
@Ron - You should better try to get the Amazon Web API to work since it also handles bounces.
If you follow the video to create a new amazon ses user, then you generate new access keys and use those keys for creating a new web api delivery server in mailwizz, then it will work.
I'll delete the current Amazon SES Web API on our mailwizz account...delete all users on the Amazon IAM console.. and start fresh..

Just let me know..what username and password should be given on the amazon web api delivery server on mailwizz??

Policy should be PowerAccess or AmazonSESFull Access??
username - Access Key ID
Password : secret access key??

Host as in same