Amazon Send Error

Dan O'Shea

Member
I've been using my local server for the past few months when needed and have not used Amazon's SES even though it is/was correctly installed and used in the past.

Now, when I try to send with one of my emails (they are all correctly verified from the Amazon dashboard) the campaign shows sent, but I don't receive it. All five email addresses - gmail, yahoo and two of my own domains do not receive the email. I click on the emails that it was sent to and I get the status - "GIVE UP".

Further, I get the following log error on each and every email address:

Signature not yet current: 20170305T231506Z is still later than 20170305T231226Z (20170305T230726Z + 5 min.)

How can I fix this?

Thanks
 

Dan O'Shea

Member
Btw, I tried changing the php.ini timezone to America/New_York as my Amazon SES is in the Eastern region and tried to send a new campaign and still the same error.
 

twisted1919

Administrator
Staff member
@Dan O'Shea - As far as i know, this is caused by the timezone on the server side (mailwizz forces utc when it starts anyway).
So what you have to do is to install NTP on your server so that it will keep it in sync with an external time server :)
 
Top