Adding SES web api error

Edmund

New Member
Hi, amazing platform you have created. I have been using sendy and recently jumped over to experience mailwizz. It's packed with more features but also more complex to set up.

I am hosting on an EC2 micro instance (eu-west-1) and also created an user with PowerUserAccess. Access keys were generated after and input into Mailwizz.
Hostname *: email-smtp.eu-west-1.amazonaws.com
Access Key ID: [Access Key ID]
Secret Access Key: [Secret Access Key]
From Email: Both domain and email verified in SES

Form saved successfully but when I tried to validate the server with an email, I got this error message:
Cannot send the confirmation email using the data you provided.
Here is a transcript of the error message:
Invalid parameter: Unreachable Endpoint

I tried with more policies (AdministratorAccess, AmazonSESFullAccess) which I gathered from some other post. Security Group includes SMTP 25 and SMTPS 465. I have yet to setup the bounce and complaints.

I tried with Mailgun and it works.

When I tried SMTP Amazon (after creating SMTP credentials), I encountered another error:
Connection to email-smtp.eu-west-1.amazonaws.com:465 Timed Out
Log data:
++ Starting Swift_SmtpTransport
!! Connection to email-smtp.eu-west-1.amazonaws.com:465 Timed Out (code: 0)

If I use port 25, this error appears:
Failed to authenticate on SMTP server with username "XXXXXXXXX" using 2 possible authenticators

I tried:
telnet email-smtp.eu-west-1.amazonaws.com 465
and it connects.

Any help will be appreciated, thanks.
 
Last edited:

Edmund

New Member
Hi twisted1919, thanks for the reply.
Point 1 & 2 checked. For point 3, as I am not using cpanel, any other ways for me to do that?
 

twisted1919

Administrator
Staff member
@Edmund - Let's try this please. Backend > Settings > Common and select PHPMailer as the system mailer, then try saving the delivery server again, does it make any difference?
 

Edmund

New Member
Appears that I can't connect to the smtp server.
I am migrating my instance to us-east-1 and use php5.6 instead of 7.0.
Will feedback shortly.
 
Top