Add reCaptcha to Opt-In

I've been getting a lot of spam opt-ins to my newsletter on my website. I want to put in a recaptcha, or something to stop it.

please help me, how to resolved it
 

Willi

New Member
I need to resurrect this question, please.

I've been trying to add a captcha, or reCaptcha, to a form on a site I manage. I cannot get any kind of captcha to show up.

I have activated the reCaptcha by going to Extentions > Recaptcha > Enable (within the main admin control panel), as suggested above. The problem is that I'm totally stuck from there. I go to the forms in the backend by going to:

Lists > Lists > Overview button (the "i" icon on right) > Forms box (view) > and either grab the code there or the iframe. Not sure if this matters, but I have several "customers" and the list I am trying to add a captcha/reCaptcha to is one of my customers. I had activated the Recaptcha extension through the main admin account.

I had also created some keys in the Api section although I admit to not knowing what to do with the keys thereafter; I don't see anywhere to add the private/site keys.

I'm assuming this system does have a reCaptcha gizmo in it that shows up on activation, right? Is there another spot where I'm supposed to activate reCaptcha, as above, but targetted to the particular customer? If so, I don't see it anywhere.

Thank you in advance.
 
Last edited:

twisted1919

Administrator
Staff member
@Willi - The recaptcha will only show on the forms from your mailwizz domain, okay? They won't show in the generated embed code, that is just impossible.
So if you go to Customer > Lists > Your email list > Overview > List Pages > Subscribe page and you click on the Preview Url, you will then see the recaptcha form there and only there.
 

Willi

New Member
Thank you, @twisted1919 for your quick response.

Okay, so I logged into the customer's backend (logged in through the mailwizz domain), went to Lists > Lists > Overview (the "i" icon) > Pages box (blue colored box) > black colored "Preview it now!" button (to the immediate right of "Your subscribe form url is:" field) > saw my form WITHOUT a reCaptcha/captcha displayed. Where else can I look? I'm sure the answer is staring at me right in front of my face.

I do appreciate any help you provide.
 

Willi

New Member
Again, @twisted1919, thank you for your quick reply. You rock!

1. Yes, I confirm that the reCaptcha extension is enabled in the main control panel, in Extend > Extensions > Recaptcha (see post below this one for screenshot). The little check mark icon has been flipped to look like an eye icon and a disable icon to the right of it.

2. Within the customer's control panel, there is a public and private key in the section called Api key (last menu item on the left column of control panel). Please note that the keys were generated by the Mailwizz system, which I found interesting. I did not get them from reCaptcha (Google). The system did not allow me to replace the keys anyway with others I already had associated with the client that Google (reCaptcha) had provided. I don't know if that is the issue or whether I'm even looking in the correct place. It does look different than the screen capture you provided above.api-screenshot.jpg
 
Last edited:

Willi

New Member
Screenshot of extension activation within the main control panel (ourselves...the main admins).

recaptcha-activation.jpg recaptcha-activation.jpg
 

twisted1919

Administrator
Staff member
@Willi - AH, i get your confusion. The API Keys area in mailwizz is for external customers to access your app, it has no connection to recaptcha.
In the extensions list, click on the eye icon for recaptcha, this will redirect you to the extension settings page from where you can enter your google api key and enable it for various sections of the website ;)
 
Top