Maiwizz Install - Requirements - IMAP extension warning

Marko

New Member
Webmin-Centos7 on virtual server (time4vps)
IMAP extension Warning MailWizz Core -
upload_2019-2-22_15-2-31.png

I've tried everything to get this to pass - please help. Email works through Thunderbird, both sending and receiving so the IMAP is correct.

The PHP-imap is installed. The Virtualmin configuration is correct.

[root@xxxxxxxxxxx.xyz ~]# yum install php-imap
Package php-imap-5.4.16-7.el7.x86_64 already installed and latest version
Nothing to do
Thanks in advance.
Mark
 

frm.mwz

Well-Known Member
Webmin-Centos7 on virtual server (time4vps)
IMAP extension Warning MailWizz Core -
View attachment 7111

I've tried everything to get this to pass - please help. Email works through Thunderbird, both sending and receiving so the IMAP is correct.

The PHP-imap is installed. The Virtualmin configuration is correct.

[root@xxxxxxxxxxx.xyz ~]# yum install php-imap
Package php-imap-5.4.16-7.el7.x86_64 already installed and latest version
Nothing to do
Thanks in advance.
Mark
The php version applicable to your mwz folder may be different from your system php version.
 

Marko

New Member
Thank you for your response, If possible, could you please explain how I would determine this and correct it?
 

frm.mwz

Well-Known Member
Thank you for your response, If possible, could you please explain how I would determine this and correct it?
You need to look around your webmin/virtualmin (and their forums) and see where the php version is chosen for the system and for the mwz folder.
 

Marko

New Member
I finally figured it out. I had to install the most recent version of PHP and then had to fix the Zip-archive. It is now finally working. Thanks for your help.
 

angeli_reyes

New Member
i did this and it worked. i'm using centOS 8


[root@server2 ~]# dnf module reset php
[root@server2 ~]# dnf module install php:remi-7.2
[root@server2 ~]# dnf install php-imap
[root@server2 ~]# dnf install php-pdo
 

abdelilah

New Member
hello everyone i have install mailwizz but i skipped the install imap extension
so when i added a bounce server i notice that it doesn't work properly
i'm asking if there is any way to install imap extention and chek it if it fonction as it must be
without desinstall and install mailwizz from 0
 

laurentiu

Active Member
Staff member Support Staff MailWizz 2.0 Tester
hello everyone i have install mailwizz but i skipped the install imap extension
so when i added a bounce server i notice that it doesn't work properly
i'm asking if there is any way to install imap extention and chek it if it fonction as it must be
without desinstall and install mailwizz from 0
The way to install the extensions depends entirely on your environment, so you'll have to search for that, but generally, from command line it should be something like:
apt-get install php-imap
or
apt-get install php7.2-imap

Then restart the web server and see if that works.
 

abdelilah

New Member
The way to install the extensions depends entirely on your environment, so you'll have to search for that, but generally, from command line it should be something like:
apt-get install php-imap
or
apt-get install php7.2-imap

Then restart the web server and see if that works.
thanks for your replay . yes i did and i installed the last version php-imap-7.2.34-6.el7.remi.x86_64 but still does not work properly . i will uninstall mailwizz and install it from the beginning
 

twisted1919

Administrator
Staff member
i will uninstall mailwizz and install it from the beginning
I don't think this will help TBH.
yes i did and i installed the last version php-imap-7.2.34-6.el7.remi.x86_64 but still does not work properly
Make sure the extension is enabled as well... not just installed.
If you go in mailwizz in backend > misc > php info, and search for imap, what do you find?
You should have something like:

Screenshot 2021-08-09 at 17.58.16.png
 
  • Like
Reactions: Wah
Top